2

My mail server is hosted with some third party and not synch with our AD. We found that Email Id attribute is blank in AD as well as for SharePoint user profile. We manually added User email ID's in AD and run User Profile Sync All and Incremental sync. But SharePoint not picking up the Email IDs.

any suggestion !

2

This might caused because the User Profile Service Application was trying to sync the Work Email with the AD attribute ‘ProxyAddresses’ and not with the attribute ‘mail’.

Configure the User Properties import for Work Email:

  1. Check if the User Profile Sync Service has started.
  2. Go to the User Profile Service Application.
  3. Click on Manage User Properties and navigate to Work Email.
  4. Check if your attribute of Work Email is mail. If it is "ProxyAddresses" than change it to mail

Start a full sync after changing this setting and the EMail addresses will be filled in for User Profiles.

  • Thanks for suggestion Hardik... I checked, Work Email is already selected as Email, I run increment sync as well as full sync... but SharePoint still not picking up the Email from active directory ! – cjs Apr 12 '16 at 6:50
  • Please restart the User Profile Sync Service via the Central Administration and then run a full sync again. Double check your AD connection properties too. – Hardik Apr 12 '16 at 7:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.