0

I have taken backup of content DB of one web application from production database server and restored to my development database server. content DB restored successfully. Content DBs have exactly same Names and scheme info in both production and in development and are connected to same web application name in both environments. I just take back up from production db because of more content in production. but when i tried to view the app in browser i got this: 404 FILE NOT FOUND. Then I reset IIS and browse the site from IIS Manager, I got this:

HTTP/1.1 200 OK Server: Microsoft-IIS/8.0 Date: Fri, 08 Apr 2016 13:21:36 GMT Connection: close

Then I see from central admin, that content DB was not attached to existing Web app. I tried to attached db to existing web app, then i got this error:

"This content database has a schema version which is not supported in this farm"

My app was working fine in development environment before content DB restore.

Whats the problem?

  • App, as in list or as developed app? – Christoffer Apr 8 '16 at 13:41
  • App means Web Application that was already created and was woring fine. But after content DB restore, it that error – SPBeginer Apr 8 '16 at 13:58
  • So you attached a second content database to the web application in your development environment? Could it be that you have two root site collection for the same webapplication? One in each content database? – Christoffer Apr 8 '16 at 14:06
  • I tried to attach same content DB after restoring with same content DB name, But I got this error: "This content database has a schema version which is not supported in this farm" Any idea to fix it? I have updated my question – SPBeginer Apr 8 '16 at 15:25
  • Sounds like you have tried to restore with a database that were with an older patch version. Correct? – Christoffer Apr 11 '16 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.