1

I'm unable to break permission using SharePoint 2013 Designer Workflow, it throws this error:

{"error":{"code":"-2147024891, System.UnauthorizedAccessException","message":{"lang":"en-US","value":"Access denied. You do not have permission to perform this action or access this resource."}}}

The Response code is: Unauthorized

I ran this workflow using a site collection administrator account as well but same result.

I have implemented the permission break in App step as well, but same result.

If we want to break the permission from SPD 2013 Workflow is it necessary to have the REST API call in App step even if the user who will trigger the workflow has full control?

1

In this case you need to give full permission to your workflow app on tenant so it will break permission on list item or you can add new permission. It will not give System.UnauthorizedAccessException.

<AppPermissionRequests>       
    <AppPermissionRequest Scope="http://sharepoint/content/tenant" Right="FullControl" />
  </AppPermissionRequests>
0

Follow instruction at "Grant full control permissions to the worklow" section of this article. The official doc is here. And yes, you'll need to wrap the action inside an app step.

  • Are you running this action in an Impersonation step? – Ramana Viswanadha Apr 6 '16 at 16:57
  • Thank you for the reply, I had actually started with both of these articles but getting the error – Khateeb Mohammed. Apr 11 '16 at 6:15
  • @RamanaViswanadha Impersonation step is available in SPD 2010 Workflow and not in SPD 2013, correct me if I'm wrong – Khateeb Mohammed. Apr 11 '16 at 6:16
  • @KhateebMohammed you are right. Why would they get rid of a pretty useful action like the Impersonation step? – Ramana Viswanadha Apr 11 '16 at 13:06
  • @Aziz Kabyshev, any other thing I can try – Khateeb Mohammed. Apr 13 '16 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.