0

Whenever I try to run SharePoint enabled LightSwitch application in debug mode I get this error:

Could not load file or assembly 'Microsoft.LightSwitch, Version=10.0.14.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

Any help would be appreciated

0

Once, I faced the same issue while I was working on some SharePoint enabled LightSwitch app. What I did, I simply go for all the product updates of my Visual Studio which were necessary. You can also give it try to get rid of the mentioned error you are dealing with, all you have do is to follow the given below steps:

  1. Open Visual Studio 2015 or whatever version you are using
  2. Now you need to click on the notification button that can be seen at right side of the title bar of visual studio home screen
  3. A ‘Notification Window’ will open up containing the list of required updates
  4. Click on any particular notifications
  5. A dialogue box named as ‘Extensions and Updates’ will open up
  6. Now make a click on ‘Updates’ and then ‘Product Updates’ located at the left side pane of the dialogue box
  7. Finally do ensure that you have updated all the required updates

In case, there is trouble doing it you can go for the graphical representation of the above mentioned steps: http://blog.itlinksolutions.com/post/2016/04/07/Could-not-load-file-or-assembly-Microsoft-LightSwitch-Version-100140-Culture-neutral-PublicKeyToken-31bf3856ad364e35.aspx

Hoping that it will resolve your problem. Thank you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.