2

I do not want Search functionality in my SharePoint Server. Therefore I wanted to STOP the Search Service.

But, when I disable and Stop the Search Service, it automatically start after time of interval. Any clues why it starts automatically even after stopping?

2

Try using PowerShell commend

Stop-SPServiceInstance -Identity

Example

Stop-SPServiceInstance 67877d63-bff4-4521-867a-ef4979ba07ce

Where is the GUID of the service. If you do not know the service GUID, you can retrieve a list of all services in the farm together with their GUIDs by using the Get-SPServiceInstance cmdlet.


Or if this not works then use following comment in PowerShell

Get-SPEnterpriseSearchServiceInstance -Local | Stop-SPEnterpriseSearchServiceInstance

-1

Go to service property. Change logon with wrong user password. Save it with disabled type. It will not start automatically.

  • But, I Think It's not a proper way, because It continuously throw error in my event log @viraj – Amit Koyani Apr 4 '16 at 6:21
  • 1
    At first start search service from local services. Pause all crawling from Central admin >> Manage Service Application >> Search Service Application >> Content Sources. Now again disable search service from local services and check it. – Viraj Gorajia Apr 4 '16 at 6:57
  • Wrong way to stop search service. – Kaushal Khamar Apr 4 '16 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.