0

Question may be basic, but scenario is not understood. scenario is I am having the SharePoint 2010 installed on Windows Server 8 under Domain1. My Developer machine also under Domain 1. But while creating the web part it is asking to validate the site url. I am providing http://myserverIPAddress:Port/sites/xyzsitename On developer machine I am logged in with server domain user. But it is not resolving site url.

It is showing me error like :

enter image description here

Also one more thing need to be added, when I selects the Visual Webpart template in VS 2012 it ask me to open VS in different permissions elevated permission I guess. But the domain user with I am logged in is not administrator for developer machine. don't understand what is going on.

9
  • give access to current user in content database Apr 1 '16 at 9:28
  • Means in sql content db => security=>login do I need to add domain user on server ?
    – Red Swan
    Apr 1 '16 at 9:30
  • yes, add server roles dbcreator,public,securityadmin,sysadmin Apr 1 '16 at 9:32
  • server role in sql server in mai security node or to sharepoint db only?
    – Red Swan
    Apr 1 '16 at 9:34
  • Go to SQL Server --> Security --> login --> Your user --> Properties -->Select server roles and give access Apr 1 '16 at 9:35
1

To work with server , you can't use another machine to deploy solution. You must need to login to server and develop solution there only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.