I have enabled multiple content types in a document set. However I do not want them all to be visible when selecting Files>New document.

I know how to control this in a document library via the library settings, but how do i control this in a document set? The document set doesn't seem to inherit the same settings as is defined for the library where the document set resides (in terms of what content types are visible when selecting Files>New Document).

1 Answer 1


The content types used (and available from the New Document button) in a document set is controlled from within the specific document set settings. This has to be set up before creating the actual document set.

Go to the library setting and select the document set content type that you wanna modify, click on Document Set Settings and in the first section, Allowed Content Type add the content types that you would like to be available from the New Document button. Click OK.

And as i mentioned before, this has to be done before creating a document set, as the content types/new item button won't update in the sets that are created before this change.

I found that Marc D Andersson covered a part of this topic. Found in his blog here.

  • Hi Christoffer, Thanks again for your input. I have though already done the above to add content types to my document set. The behaviour I would like though is that when a new user now enters the document set and selects File >New document is to NOT see all the available content types. I only want them to see certain ones. I can do this in a document library by going to library settings, then 'Change new button order and default content type' and ticking or unticking the 'visible' tick box. However this setting does not seem to cascade down to the document sets created within a library... Commented Apr 3, 2016 at 23:59
  • Murray, that is weird. Following those instructions from here or the blog should help you specify which and what content type that is available in a document set. Did you add the document content types to the Document set settings before or after creating the actual DS? This is a little bit tricky. The only content types that should be available form whitin a document set should be those that are made available from the specific document set settings > allowed content types. Commented Apr 4, 2016 at 7:39
  • I added new content types to the document set content type AFTER i had created the document sets. Perhaps that is the problem? Commented Apr 5, 2016 at 4:53
  • Yea, that did not work for me when i did my changes. I had to add the content types to the document set and then create the actual set. If possible, try just to create a new set when added some additional content types and see if the changes is reflected in the new set. OR see if triggering the timer job "Document Set template update - Propagates changes that are made to the document set template to the existing items." works for you. Commented Apr 5, 2016 at 7:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.