0

I have a SP 2010 Farm with 2 WFEs. The WFEs are load balanced and users, when they get switched (round robin, usage based polling on load balancer) they have to go in and deselect the compatibility mode (global policy sets the mode as checked). The symptom is most often see with InfoPath forms and workflows (when loading the forms for the Start Cancel buttons) and that is their clue to either check or uncheck. I have verified that the Web.Config files are a match at the site level. I am wondering if it is an IIS configuration also. I just can't seem to find the answer.So now the questions are

  1. Where is the setting that is causing the difference between the two servers?
  2. And how is it changed?
  • Cannot answer to any of the questions as cannot definitely say what is the cause of the compatibility mode. Couple of things to try to narrow it down: 1. compare the http output of the pages. 2. Run PSconfig on both servers maybe after one update PSConfig wasn't run on all required servers. – Marek Sarad Mar 31 '16 at 17:01
  • Both servers are supposedly identical. they do match as far as all patches for OS and SharePoint per PSCONFIG and OS comparison tools. Something I read ages ago regarding IIS config files. Hoping someone can recollect what configurations need to be adjusted on the IIS or site level configuration. The problem is noted during the use of workflows and InfoPath forms specifically. Anytime compatibility mode is set against one server the forms fail (such as the Start Cancel form that workflows begin with) and the other way around on the other server if your setting is to use compatibility mode. – Greg McAllister Apr 5 '16 at 15:36
0

Compatibility View mode is an Internet Explorer setting. This must be enabled for SharePoint 2010 sites as Edge mode in IE is not supported with SharePoint 2010 (and partially supported for 2013, depending on patch level).

  • Thanks Trevor. Our Group policy set compatibility mode. That is the problem. When connected to one server I have to turn the mode off in order for Workflow Dialogs to pop up (the Start Cancel form as an example). I am trying to determine if there is a web.config entry somewhere that could have been set by admins on IIS to adjust that issue. – Greg McAllister Apr 5 '16 at 15:40
  • To determine that, what you could do is grab the web.config from the Web Application on each server and use Notepad++ to compare the files. – Trevor Seward Apr 5 '16 at 15:41
  • Comparison is that both are exactly the same. Should I compare something else because it seems to truly be a server difference (more than likely at the IIS level) and I just don't know what would need to be checked at this time, especially since compatibility mode is 'supposed' to be mandatory? – Greg McAllister Apr 21 '16 at 19:33
  • Also - the users are using IE 11 - no Edge is being used. Another interesting feature is that regardless of which server the user is balanced to, Chrome and Firefox always work. – Greg McAllister Apr 21 '16 at 19:35
  • When I say Edge, this means Edge mode in IE 11, not the Microsoft Edge browser. That said, could you just build up a new FE and eject the problem FE from the farm? – Trevor Seward Apr 21 '16 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.