8

I have an extranet solution in SharePoint 2013, running on Windows Server 2012 r2. When I try to use the "open in explorer" command in any SharePoint document library, I get the following message:

"We're having a problem opening this location in File Explorer. Add this web site to your Trusted Sites list and try again."

First, some more detailed information about my setup:

-This is a development server, so everything is running on the same machine.

-I'm signed in to the development server on an account with all privileges under the sun.

-Possibly related- I'm also not able to reach any of my sites via mapping network drives ("add network location" via explorer).

Next, here is an exhaustive list of things I've already tried after over a week of research, trial and error:

Browser:

-Using 32-bit Internet Explorer (my understanding is that Chrome, Firefox, Edge, and 64-bit IE cannot utilize the "open with explorer" option).

-Added all of my sites to the Trusted Sites list in 32-bit IE.

-Also tried adding them to the Intranet zone with identical settings.

-Enabled all the commonly suggested ActiveX controls/add-ons/etc in IE.

-Used the "emulation" tab in IE11 developer tools to emulate IE10.

-Added all sites to compatibility view in IE11.

^Between each attempt, cleared the cache in IE (i.e. after I changed anything, including things further down this list).

SharePoint:

-Checked alternate access mappings as per (https://goo.gl/kkbyXb).

-Checked managed paths as per (https://goo.gl/1TErTM).

-Web application in question uses claims-based authentication (Integrated Windows Authentication, NTLM). Basic authentication is enabled as well.

-Client integration is enabled for said web application.

-The account I'm using has full access to all the resources in question.

Windows

-WebDAV is installed/running.

-WebClient is installed/running (including Desktop Experience).

-Registry changes (WebClient parameters- BasicAuthLevel to "2", AuthForwardServerList encompassing all of my sites).

-User Account Control set to "low", then disabled.

-Installed all recommended updates/hotfixes remotely applicable to the issue.

Other Potentially Useful Information

Until I enabled "login automatically with current user credentials" in IE, the "open with explorer" button was prompting for credentials before displaying the aforementioned error message.

I used Fiddler to try and see what was happening when I clicked "open with explorer," and it's arguably only confused me further. I see a "401 UNAUTHORIZED" error when I try to open the library in explorer view. This almost makes sense given the button was prompting for credentials, but it begs the question: if my admin credentials won't pass, what is it looking for?

tl;dr

I've tried every solution I could get my hands on after extensive research into the issue. I split them up here logically, not chronologically, but by now I've tried every permutation of the above solutions that I can imagine making any sort of difference.

The goal here is actually just to get the path of a document within the library and pass it to an Excel Connection Manager in an SSIS package. I mention that because, at this point, I'm willing to try a workaround if one exists.

  • Can you check IIS logs at WFE's? You'll need all WebDAV related entries logged right at the moment of access attempt – Aziz Kabyshev Mar 30 '16 at 20:15
  • Have you tried using Open with Explorer from a client machine and not the server? – iOnline247 Mar 31 '16 at 0:34
  • I wonder if it is anything to do with the cached credentials. SP Online requires remember me box to be checked but I guess this is not relevant on on-prem. Can you try to go to credential manager and delete the ones corresponding to your SharePoint login and try again ? – Charles Jul 8 '16 at 13:03
  • If you're getting 401s locally and you're using NTLM auth, then the loopback mechanism might be in play (though it doesn't explain how you're getting to the site in the browser). – Greg W Oct 3 '16 at 10:56
0
  1. Are you logged in via SSO?

    • If you are logged in via SSO, the account you used to log in the server should be the same as the account in Sharepoint.
    • Else, option "Keep me signed in" on the login page should be checked.
  2. If there are PC that can access this server, try accessing from those PC. If those works, may try comparing their IE settings.

0

I had a similar issue a while back. All the configuration was right, but the "open with explorer" issue persisted.

In my case it turned out to be that there were other "trusted sites" entries for other resources that were not valid (wild cards in the wrong place) which caused Internet explorer to stop processing the rest of the sites in the list - including the SharePoint sites.

Fixing this enabled "open with explorer" to work in Internet explorer as expected.

Also, have you thought about manually constructing the WebDAV links manually?

0

Wild guess: Don't use the SharePoint system account. Use a new AD user that's able to logon to your server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.