1
  • SharePoint 2010 Enterprise
  • Out-of-the-Box Approval Workflow
  • Error only occurs in 1 site collection on any library
  • Is a host-named site collection
  • Works fine on other HN site collections in Farm
  • No modification has been made in InfoPath

See below error message:

Edit or View Form in Modal Dialog

ULS logs shows

The form template failed to load. (User: DOMAIN\first.last, Form Name: Template, IP: , Request: http://site.domain.com/_layouts/WrkTaskIP.aspx?List=578d676d-0bcd-4049-9faf-857bb9d77cca&ID=3&ContentTypeId=0x01080100C9C9515DE4E24001905074F980F93160003A15057E2AF34B67B32E14B94EB7040900D6EDD18586B43441B49F373D71D6093C&IsDlg=1, Form ID: urn:schemas-microsoft-com:office:infopath:workflowInitAssoc:-AutoGen-2009-07-30T07:17:57:12Z:1033, Type: InfoPathLocalizedException, Exception Message: There has been an error while loading the form. 'd:SharePointListItem_RW/d:Incident File Number' has an invalid token.)

Fixes found on Google and already tried:

  • IIS Reset
  • Deactivate and Reactivate SC feature
  • I can see the form correctly in Designer
  • New tasks(not approval workflow related) in the same list display fine
  • Approval workflow behaved correctly in the past according to users

Any suggestions before I delete the site collection and reconnect the database?

  • Does your Workflow Task content type have an added field (Incident File Number) in it? – Erin L Mar 29 '16 at 18:50
  • Good observation. That is a result of a VS solution that affected our whole farm. It has been there a couple of years and is present in site collections that work correctly. It would be synonymous with "Item" in a normal farm. – Jammin4CO Mar 29 '16 at 19:02
  • It sounds like the task form (which is an infopath form) doesn't have the XML to handle the custom field. All I can think you should do is retract and redeploy the VS solution. – Erin L Mar 29 '16 at 19:07
  • @ErinL Where can I find the task form? I looked for _layouts/WrkTaskIP.aspx in /14/bin/layouts and found it, but that affects the whole farm and this works everywhere else. You mentioned XML, where would that be stored, if it became corrupt? – Jammin4CO Mar 29 '16 at 19:11
  • Also, the VS solution you mention has nothing to do with OOTB Approval Workflows or their content type. It only renamed the title of the base Item content type. – Jammin4CO Mar 29 '16 at 19:16
1

I have found a workaround, but I still don't know what caused it. If I edit the workflow and have it write tasks in a "new task list", my issue is resolved.

  • delete the xsn file and republish the workflow. – Taran Goel Apr 14 '16 at 13:31
  • I just deleted the xsn file for the edit task form from the _catalog/wfpub folder. I then republished the workflow. I have the same error in browser. Sorry. This is the kind of answer I expected to fix this issue. Maybe I'm not doing it right? Perhaps you could expound on your comment in an answer? – Jammin4CO Apr 14 '16 at 13:47
  • is this a custom edit form in Infopath? – Taran Goel Apr 14 '16 at 13:55
  • No. It is the edit task form on an OOTB 2010 Approval workflow. (globally published) – Jammin4CO Apr 14 '16 at 14:07
  • cool, you need to open the workflow in designer -> in the bottom right there would be a xsn files -> delete all of them -> Republish – Taran Goel Apr 14 '16 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.