0

We get the following error when trying to deploy a SharePoint hosted app in SharePoint Online. It worked fine till yesterday.

Install app for SharePoint:
Uploading the app for SharePoint...
Error occurred in deployment step 'Install app for SharePoint': Access denied.
You do not have permission to perform this action or access this resource.
========== Build: 1 succeeded or up-to-date, 0 failed, 0 skipped ==========
========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

I have full control on the site collection. We tried with other users who have full control. But no luck.

Also, I tried creating a test app with default template on Visual Studio 2013 and 2015 in various machines. No luck.

The problem is limited to one site collection only. I can create apps on another site collection where I have full control.

0

In the application, Please try to login to the site before deploying the app. You can login by changing site in Properties tab of the project.
Note: Try to login with different site and then try with your Source site
enter image description here enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.