0

Hi I developed a SharePoint application in Visual Studio targeting our online development site ... http://arpcdev/sites/ipsc/. I cannot target our staging site remotely. This is farm solution which contains a WCF Restful service and a sitepage.

I created a WSP package by publishing it. Is there a way to deploy the WSP package to our staging site http://arpcStagin/sites/ipsc/ using the WSP that was created using the dev site?

2

If it the Farm solution( full trust code) then you have to deploy it to sharePoint Staging farm.

You can use the powershell like this.

Add -SPSolution "path of file i.e. C:\test.wsp"

Install-SPSolution –Identity "test.wsp" –WebApplication “http://target web application “ –GACDeployment

But if it is Sandbox solution then you can do it like this.

Add-SPUserSolution -LiteralPath "C:\SandboxTest.wsp" -Site htttp://site name

nstall-SPUserSolution -Identity SandboxTest.wsp" -Site htttp://site name
  • More resources in addition to this answer: technet.microsoft.com/en-us/library/cc262995(v=office.14).aspx (the article is for SharePoint 2010, but it also applies for 2013 farm solutions). One other source - jaxsharepoint.blogspot.lt/2013/06/…. There's plenty of other information online on how to do it. – Justas Černiauskas Mar 22 '16 at 20:23
  • Hi Waqas thanks for the quick response. It works! My new sitepage and WCF service are all there.However, I am getting a HTTP 400 (BAD Request) in Fiddler when I start consuming my WCF Restful service from my new SitePage. Do you think this has something to do with the deployment? – Tigershark6 Mar 23 '16 at 13:29
  • Not sure, I think if you open a new question and provide the details about the error...check the logs etc...then maybe someone will help you....because this was not scope of the question and less people read the comments. – Waqas Sarwar MVP Mar 23 '16 at 13:31
  • and if it solve the deploying issue then mark it answer for others and my benfits. – Waqas Sarwar MVP Mar 23 '16 at 13:31
  • Hi Waqas, I am new to this forum. How can I flag this issue as "Answered" – Tigershark6 Mar 23 '16 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.