-1

I've a list with OOB approval workflow. on top of that, i created a workflow to send an email depending on the status, when the item is changed- if approval status="Approved", send one mail, else if approval status="Rejected", send another mail. But even if I approve the entries, mails are not fired. On checking, I found that though the entries are showing as saved with "approved" status, they are suddenly modified to "Pending" status. I can see that the item is modified on behalf of workflow. (I did another check- set the condition in workflow as send mail if status="pending". then the mails are sent). this means even though the item is approved or rejected for a moment, it's again changed back to "Pending" somehow. How can I change this behaviour?

I don't want to use a custom field to denote the approval status instead of the OOB workflow, as in that case I'll not be able to use the "approve" permissions, or I cannot hide this custom field from new entry forms.

  • You said it's modified on behalf of the workflow. The approval workflow, or the email workflow? – Erin L Mar 21 '16 at 13:44
  • How can I know which workflow did that? the item page shows "Last modified at 3/21/2016 9:25 PM by Workflow on behalf of Jack". if I approve/reject, it's showing as "approved"/"rejected" for about a minute. then it's changing back to "Pending" – Jack Eapen Mar 22 '16 at 4:31
  • Temporary disable your custom workflow and see if it still happens. – Erin L Mar 22 '16 at 13:07
0

The status changing back to pending sounds a little weird, first step would probably be to work out how that is happening.

Maybe disable your email sending workflow and ensure the item maintains it's approved status normally.

If that works ok, are you sure your email workflow isn't updating the item, which would probably cause its status to change?

  • Yes, I've already checked that. if I switch off the email sending workflow, items are changing to approved status – Jack Eapen Mar 22 '16 at 4:14
  • with the workflow on, if I approve/reject, it's showing as "approved"/"rejected" for about a minute. then it's changing back to "Pending" – Jack Eapen Mar 22 '16 at 4:32
  • any suggestions for my problem, please? – Jack Eapen Jun 7 '16 at 4:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.