2

In SharePoint 2010 Service Pack 1, we are having trouble with ListData.svc. In most cases, it correctly returns data from a list. However, there are a few lists which don't work and instead return the following error (friendly error messages turned off):

<?xml version="1.0" encoding="utf-8" standalone="yes" ?> 
- <error xmlns="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata">
<code /> 
<message xml:lang="en-US">An error occurred while processing this request.</message> 
</error>

Where can I start with troubleshooting? I cannot see any place where anything useful is logged.

Edit 17/03/2016: I've noticed that the lists are quite large: they range from having between 33,000 and 116,000 items. Could this potentially be the issue?

Edit 18/03/2016: I've been advised that the farm administrator was creating new content types and running the Content Type Hub Publisher/Subscriber jobs manually before the issue occurred. Could this be a clue?

Edit 21/03/2016: I've noticed that all lists have a "Last Modified" time of "2 weeks ago", which roughly lines up with the time that the new content types were created (see edit above on 18/3/2016)

Edit 21/03/2016 @ 3pm: OK, bear with me here... I saved a copy of the problem list to a new template. I then instantiated a new list using the template, and the listdata.svc displayed the list correctly (though it was empty). HOWEVER, as soon as I add a single new item to this list it fails to display in listdata.svc. When I delete this item, the list starts working again through listdata.svc (even though it's empty). I even tried removing almost all fields so that it would be similar to a very basic list type, and it still had problems. What could this indicate?

Edit 23/03/2016: For some reason, the listdata.svc will start returning values if the "Title" column is not empty. However, this is new behaviour, since in my particular list the Title field has allowed empty values for a long time previously. What could have changed?

Edit 4/4/2015: I've turned on Failed Request Tracing, and get the following back (not sure how helpful this is). Kind of getting desperate here... :

ModuleName: ManagedPipelineHandler Notification: 128 HttpStatus: 500 HttpReason: Internal Server Error HttpSubStatus: 0 ErrorCode: 0 ConfigExceptionInfo Notification: EXECUTE_REQUEST_HANDLER ErrorCode: The operation completed successfully. (0x0)

Edit 27/4/2016: There was no resolution: the business decided to create PowerShell scripts to automatically set Title values to a single space character (" ") for all items every day, before listdata.svc could be used by an external application

2

I was having this same issue on two particular lists on our SharePoint 2010 site. I read some posts that mentioned it could be caused by lookup fields, but neither problem list had such fields. Other posts mentioned people/person fields, I had them but I ruled that out as well.

So I turned to the calculated columns in my list. I had three. I set each one to just a calculation of "=1" and saved, and noted that the ListData.vsc started working!

While two of the calculated fields had much more advanced formulas, after process of elimination I determined that this calculated field is the one causing the problem for me:

Field Name: "Expected Launch Date"
Field Formula: =IF([Call 2 Completed]=0,"TBD",[Call 2 Completed]+7)
Return Type: Date Only

You might see the problem now -- my simple "IF" formula is returning text "TBD" string for a column with a type that must return "Date Only".

So, I changed the formula to the following and my list is still working now.

New Formula: =IF([Call 2 Completed]="","",[Call 2 Completed]+7)

Read as "If Call2Date is null, use null. Otherwise, add 7 to Call2Date"

  • Thanks for the quick reply; unfortunately these lists don't have any calculated columns :( – DRVR Mar 17 '16 at 2:20
0

A list, survey, discussion board, or document library has the same title. I had to rename one of the items. This resolved my issue.

0

I know it's late but I just got a similar problem solved. HTH:

Problem: REST query to SharePoint 2013 failed with error: "An error occurred while processing this request."

Most queries are ok, but a particular one always failed. I fine-tuned the 'filter' field to finally narrowed it down to 1 single item.

I opened this item to find that a calculated column has the value

'#NAME?'

The formula itself was right.

My Solution I didn't want to change the last modification date of this item. So I used PowerShell to edit some dumb remark-type of field and then save it with

$item.SystemUpdate()

Voila! The calculated column then gave the right value. No more error.

Points to note:

  • A direct SystemUpdate() call without modifying the item could've worked. I'll try next time
  • In this

    An error occurred while processing this request.

    case, the ULS really didn't help. Nothing relevant was logged.

Sorry the problem was solved before. No screendump here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.