2

My only choice is Wiki page in the New Document selector of my Site Pages library. How can I restore the selection for a new Web Part Page? I have Publishing site feature turned on. I have toggled it on and off to see if it makes any difference, but it does not.

Thanks!

Leon

0

Mine looks like this. Yours does not? enter image description here

Does your library settings have both content types? enter image description here

  • No, I am only seeing Wiki Page option... – Leon Bryant Mar 15 '16 at 19:20
  • Then all you need to do is "Add from existing site content types" – Jammin4CO Mar 15 '16 at 19:22
  • So, I'm fairly new to 2013. Where do I go to "allow management of content types?" I do not see them displayed in the List Settings page. – Leon Bryant Mar 15 '16 at 19:23
  • Go to advanced settings, (see image above). Choose Allow management of content types. You will now see the "Add for existing site content types". (see image above) You will find "Web Part Page" as one of the options. You can go back and dis-allow management of content types when you are done. – Jammin4CO Mar 15 '16 at 19:25
  • Thanks so much for your help. Alas, I do not see that in my Advanced Settings. I will post a screenshot as an answer so you can see what I am seeing. – Leon Bryant Mar 15 '16 at 19:31
0

enter image description here

Here's a screenshot of my Advanced Settings screen.

0

In the library settings, find the "Add from existing site content type" enter image description here

Then select the "Web Part Page" enter image description here

Finally, you should see the additional option in your new document pull down. enter image description here

0

You can't "Enable management of content types" directly through the library settings on the Site Pages library, but I have just discovered a workaround!

Under Site Actions, choose More Options > Web Part Page > Create. In the Save Location dropdown, choose Site Pages. Voila! You now have a web part page in the Site Pages library.

Note that this still won't add the "web part page" content type to the New dropdown in the library, nor will the "Page Library" command group appear in the Page Ribbon of this web part page, as it does with a Wiki Page in the library.

0

Go to the below URL directly to create a "WebPart Page", SiteURL/_layouts/15/spcf.aspx?List=%7BSitePages Library ID Here%7D

Note: To get the SitePages Library ID, go to Site Pages Library settings,in the URL, copy everything after "List="

0

You have to first open up SharePoint Designer and then go to List and Libraries. Then under Document Libraries open the Site Pages folder. You should see a Settings section. Under Advanced Settings you need to make sure "Allow management of content types" is checked. Content Types will now display on the settings page and then you can click "Add from existing site content types" and add the Web Part Page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.