3

I have a document library on my SharePoint 2010 site called Files. I want to create a web part on my site's home page that lists the contets of that Doc Library. So, from the home page I click on Page > Edit. In the zone where I want the part added, I click on Insert > Existing List. I find my "Files" document library under Web Parts, then click Add. My web part gets added with all my folders laid out. But, when I click on one of the folders, it shows this error:

Error The object specified does not belong to a list.

Troubleshoot issues with Microsoft SharePoint Foundation.

Correlation ID: 5b1e17c6-9fc1-4b34-a110-58f199aed0c2

Date and Time: 3/10/2016 2:46:22 PM

I've tried accomplishing this task with other Document Libraries, and am experiencing the same problem. So, I know it's not the document library. I'm totally at a loss... the files in the document library launch just fine. But the folders... no. What is going on here? How can I display a list of subfolders in a document library and have those folders be clickable in the web part?

  • 2
    Nobody? Bueller? Bueller? Yeah, thought so. SharePoint sucks. – Christine Mar 11 '16 at 18:21
  • Did you ever figure out what's wrong with the folders? Are you able to see the folders in "All Site Contents"? – TempaC Jun 17 '16 at 12:22
0

When I had this issue it was due to another web part on the site that was disrupting the way the library web part was working. If you add ?contents=1 to the URL of the site you can see all of the XsltListViewWebPart's that exist on that page. One of those might be an imported web part that is causing your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.