1

In a SP 2010 list, the Edit Item choice from the item's "link to edit menu" column drop-down menu uses the wrong form - it should use the default form instead. How do I make this change?

  • I am assuming you have access to SharePoint Designer and if you do the following open the site - yoursitename.com and click on List and Libraries in the Quick launch(LeftSide) and then track the List and click on it and then Click on Forms on the right side of the page - on clicking that you will by default see three forms - NewForm.aspx/DisplayFrom.aspx and EditFrom.aspx.Select the form that you need to make as default and select "Set as default" on the ribbon and it will make it as default – SavantProdigy Mar 10 '16 at 22:15
  • Unfortunately, that's not working in this situation. The default Edit form, EditForm1.aspx, is set, and is displaying when the Edit ribbon button is clicked from the display form (which also isn't the default display form - guessing these issues are related). – Dustin Mueller Mar 14 '16 at 15:00
  • However, from the list, when I select the check box, and from the List Tools > Items tab on the ribbon, it directs to an edit form that I've deleted & a 404. From the item in the list, if I click the drop-down button, and click Edit, I get the same deleted form. How do I force the default edit form to load in those situations? – Dustin Mueller Mar 14 '16 at 15:09
  • do you see an EditForm.aspx when you open it in Designer and that probably is the Default Form that you would wanna change it toand if it deleted by any chance try to recover it from Recycle Bin and hopefully its not more than 60days and you can recover it. If this is a InfoPath From its a whole different story and when you select the item and click on Edit Item and it will take you to EditForm1.aspx in your case - Now Edit the page in your scenario( GearIcon - EditPage) and once you do that you will get that dropdown see if you can find your EditForm.aspx if yes select that. – SavantProdigy Mar 14 '16 at 15:42
  • The EditForm.aspx was deleted, but none of the other edit forms would take when I set them to default. I ended up going into the List Settings > Form Settings, and choosing the option of "Use the default SharePoint form". This resulted in the proper default forms actually showing up. There were no InfoPath forms set up for this list at any point. – Dustin Mueller Mar 14 '16 at 18:11
1

I ended up going into the List Settings > Form Settings, and choosing the option of "Use the default SharePoint form". This resulted in the proper default forms actually showing up.

  • I had the exact same problem. I inherited the list from someone else and wasn't aware that they had created a custom Infopath form for the Edit screen. The InfoPath form didn't show up in SharePoint Designer, and InfoPath had been disabled on our server in the time period between when the form was created and I inherited the list, so I couldn't find the form I was seeing, – jrhooker Jul 26 '17 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.