2

I have SharePoint 2013 Designer Workflow which assigns tasks to users. In the email of the task I have added a direct link to the related document.

I was originally using [%Workflow Context:Current Site URL%][Workflow Context:Current Item URL%] as the hyperlink.

This was working fine for all users who had Microsoft Office 2013 installed. I ran into a problem when users with Microsoft Word 2010 clicked this link the document would open only in Read only mode - when they do have Edit rights on the document. The Enable Editing link was also not available.

I found a solution to add ms-word:ofe|u| to the hyperlink so now I'm using: ms-word:ofe|u|[%Workflow Context:Current Site URL%][Workflow Context:Current Item URL%] as the hyperlink. This is great in that it gets the document to Edit mode however it gives the user a Security Notice pop-up (for all users, including Word 2010, Word 2013, and including for the site collection administrators).

Here is a screenshot of the security warning: Security Notice

So then I found the following suggestion: http://blog.amodit.com/2014/01/how-to-make-webdav-work-in-read-write.html

However it's not working. People are still getting the Security Notice.

Any suggestions to avoid this security notice and just open the files in Edit mode from a hyperlink in an email?

  • You are right, this is regulated on Office suite desktop application side. Can you post a screenshot of security notice please? – Aziz Kabyshev Mar 9 '16 at 16:12
  • I have added the screenshot in the question. Thanks. – Maureen Mar 9 '16 at 18:44
0

Check this post in Office_Integration_&_Sharepoint blog at Technet. Follow instructions in p.6:

  1. You can make this warning go away by adding one of the two following registry keys, 14 is for Office 2010 and 15 is for Office 2013

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\14.0\common\Security\Trusted Protocols\All Applications\ms-word:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\common\Security\Trusted Protocols\All Applications\ms-word:


In fact, KB925757 describes a registry manipulations that affect those warnings in Office. You can use information in "How to enable or disable hyperlink warnings per protocol" section to turn off warnings for ms-word: protocol. Or disable them completely. Protocol-level settings are surely more preferred.

  • This looks promising Aziz. I'll give it a try and let you know. – Maureen Mar 10 '16 at 3:22
  • I'm pretty sure it will. You might want to revert changes proposed by blog.amodit.com/2014/01/…. And always take backups when altering registry. Once the solution's confirmed to work, admins can make GPO in AD to avoid manual changes to each machine. Ping me if you need help with that – Aziz Kabyshev Mar 10 '16 at 12:45
  • I don't have the "Office" tree at all in HKEY_CURRENT_USER\Software\Policies\Microsoft location in the Registry Editor. – Maureen Mar 10 '16 at 13:41
  • Just create everything that is required. This is documented, therefore supported. See 1.bp.blogspot.com/-9D9s-LT_3AA/URfTc4zR1EI/AAAAAAAAB24/…, but you'll have ms-word: at the last one – Aziz Kabyshev Mar 10 '16 at 17:16
  • @Maureen Did that work for you? – Aziz Kabyshev Mar 11 '16 at 11:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.