0

We have upgraded our SharePoint farm from 2010 to 2013, after the upgrade is seeing duplicate user profiles in User Profile service application each user with domainname\username and other with domain: username.

I tried the deleting couple of accounts manually but those accounts popped up after a crawl.

currently, I can more than 18 thousand user profile in my farm.

which is not the case.

any help on this will be appreciated.

  • Have you changed from classic mode authentication to claims mode authentication during the migration process? If so, did you complete the user migration for all content web applications during this process? – Andy Dawson Mar 8 '16 at 10:40
  • Is your forest name different from the NETBIOS name in your domain? For example, is your forest MyCompnay.com and do you log in with MYCO\UserName? Are the accounts showing up as MyCompany\username and MyCo\Username? – Matthew McDermott Mar 8 '16 at 23:43
0

this thing happens in a couple of scenarios.

  • if you have the web applications in your farm with multiple authentications, i.e NTLM, ADFS or FBA. If a user login a web application with NTLM and then login a web application with ADFS..then two profiles will be in the profile store.
  • As you migrated from 2010 to 2013, if you haven't performed the migrate user on all web application that also cause the issue.
  • Another thing, how you configure the User profile Service? Do you have any filter in place?

Looks like both claims and NT profiles being generated for a user.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.