0

I'm trying to hide the Name column from the preview pane view in a form library.

What I've done in my view on SPD is change the field used in the view list (the area you hover over) to this:

    <a onfocus="OnLink(this)" onclick='OpenDialog({$thisNode/@ID}, "{$thisNode/@Titre1}")'>
      <xsl:value-of select="$thisNode/@Titre1" />
    </a>

But in the area where the information is displayed I don't need the Name column and I'm trying to hide that.

                 <xsl:for-each select="ViewFields/FieldRef[not(@Explicit='TRUE')]">
                    <tr>
                      <td nowrap="nowrap" valign="top" width="190px"  class="ms-formlabel">
                        <nobr>
                          <xsl:value-of select="@DisplayName"/>
                        </nobr>
                      </td>
                      <td valign="top" class="ms-formbody" width="400px" id="n{position()}{$WPQ}">
                        <xsl:text disable-output-escaping="yes" ddwrt:nbsp-preserve="yes" xmlns:ddwrt="http://schemas.microsoft.com/WebParts/v2/DataView/runtime">&amp;nbsp;</xsl:text>

                      </td>
                    </tr>
                  </xsl:for-each>

My bindings look like this:

            <ViewFields>
                <FieldRef Name="Titre1"/>
                <FieldRef Name="Sujet0"/>
                <FieldRef Name="Description_x0020__x0028_FR_x0029_"/>
                <FieldRef Name="Inscription"/>
                <FieldRef Name="Pr_x00e9_alable1"/>
                <FieldRef Name="Communaut_x00e9_0"/>
                <FieldRef Name="Livraison"/>
                <FieldRef Name="Dur_x00e9_e"/>
                <FieldRef Name="LinkFilename"/> <-- I want to get rid of this
            </ViewFields>

1 Answer 1

0

The best way is to open sharepoint designer and create a new custom "PrevForm".

There the complete form is rendered as normal table structure. You can just put "style='display:none'" in and you are done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.