I want to use the Office Web Apps on my environment. After the installation I configurate the trusted file location for the excel services. The Web Apps working fine in my intranet. http://my.intranet.sharepoint.com

But now I had the following problem: On my extranet site https://my.extranet.sharepoint.com it is only possible to open xlsx and pptx. When I want to open a docx I get a error window "Unexpected error in Word Web App"

Any ideas?

  • Is there a correlation ID, have you looked in the ULS, find callstack="false" in the web apps web.config and set it to true to get a verbose error.
    – Rob D'Oria
    Commented Aug 5, 2011 at 0:56

1 Answer 1


If you run your farm on least privilege settings, you can get the above error. Be aware of the security demand for the Word Viewing Service are quite high:

When you create a new application pool, you can specify a security account that is used by the application pool to be either a predefined Network Service account or a managed account. The account must have db_datareader, db_datawriter, and execute permissions for the content databases and the SharePoint configuration database, and be assigned to the db_owner role for the content databases. For more information about services account permissions in SharePoint 2010 Products, see Account permissions and security settings (SharePoint Server 2010).


So basically that means that the Web Service Application Pool needs to have db_owner permissions on each content database, which a normal service application pool should not have.

To test if this is the case, try temporarily to set the farm account as managed account for your Web Service Application, do an IISRESET and see if that fixes the case (note that you should only do this as a temporary exercise to find out if this is in fact why it fails).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.