0

We have configured F5 load balancer with https certificate and all this request till F5 are being in SSL. Load balancer does transition to http request in internal network.

I have SharePoint Site which has been hosted on iis port 80. Within network I can request it using http and can access without any problem.

But when I use https over internet I am receiving following error,

Mixed-Content The page at ' https://url' was loaded over https but requested an insecure XMLHttpRequest 'script .js' endpoint 'http://ur/". This request has been blocked; the content must be served over HTTPS.

We are giving relative paths to all resources eg: '_layout\script.js' no protocol being hardcoded.

Our platform policies do not allow us to have https within internal network. All other applications are working with same topology but not SharePoint. Please help.

Here is snapshot of error

[Error

  • Do you see any errors at SharePoint side when this happens? Maybe you should talk to F5 support – Aziz Kabyshev Mar 6 '16 at 12:20
  • No, there are no errors in SharePoint, its blocking by Browser. We can override it from browser setting but this is not the right way from user perspective. I checked with platform team, they have no clue. – Shankar Gurav Mar 6 '16 at 12:34
  • This might be an AAM issue, but then you could see entries in ULS and Application log of Windows Server. Can you please double check? Or maybe describe how your AAM is configured. – Aziz Kabyshev Mar 6 '16 at 12:41
  • Thanks, I already tried it with setting internet url as https, but that didn't helped. – Shankar Gurav Mar 6 '16 at 13:05
1

Set web application's AAM settings like these:

Default zone:

Here, FQDN is external url for SharePoint, SERVER is internal. Might be the same.

Also one might want to take a look at The final guide to Alternate Access Mappings

  • Thanks for your time for answer and link. I had tried this and observation is that it works only when https traffic is allowed from LB. We want to avoid that and would like to have http traffic only within internal network and no IIS binding with certificate is allowed. – Shankar Gurav Mar 6 '16 at 14:01
  • Yes, I got it - you're doing SSL termination (when all HTTPS is done by LB). Maybe these helps: onpointwithsharepoint.blogspot.com/2013/02/… and wwolfe.blogspot.com/2011/01/… – Aziz Kabyshev Mar 6 '16 at 14:49
  • Yes, you are right, that's the term. Let me check it tomorrow on Test server. Thanks a lot :-) – Shankar Gurav Mar 6 '16 at 15:22
  • Note that SSL Offloading is very insecure, especially when using OAuth2 tokens (SharePoint Apps, WA, WFM, etc). It won't be better to use SSL Bridging. – Trevor Seward Mar 6 '16 at 18:10
  • @AzizKabyshev, it did helped but partially, very inconsistent in response, it still gives error sometime and sometime it works, unreliable. So we finally decided to use SSL inside the network as well. – Shankar Gurav Mar 9 '16 at 4:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.