0

SharePoint Server is a Windows Server 2012 R2 and contains the Active Directory, SharePoint and SQL Server 2008.

Local domain is: test.local SharePoint host name is: sharepoint (in domain sharepoint.test.local) App domain: apps.test.local

Everything is configured like the MSDN information - I think.

Configuration of DNS Server

If I open the site collection everything works like expected. As Administrator I get an error during the app installation. As another User I can install the app successfully.

If I click on the app as an Administrator I get this. But after entering credentials I get the same message each time. At the end its an Authorization error.

If I click on the app as a other User (which is in Administrator group and site collection primary administrator).

View as administrator and user

I really don't know what's wrong. Everything should be configured as in MSDN tutorials :(

Thanks in Advance for any hints.

0

One important thing: your DNS record is probably misconfigured. The alias *.apps.test.local should point to SharePoint.test.local (i.e. the FQDN of the SharePoint server). You must have sharepoint.test.local in the column "data" of the first screenshot (i.e. enter sharepoint.test.local in the textbox "Flly qualified domain name (FQDN) for target host).

Also, note that "System Account" (and your Administrator account is probably System Account) cannot install/uninstall apps in SharePoint, so that's is expected.

  • Hmm I tried this but ping works, too. And as the "TEST\Administrator" I see that the internet explorer is asking for credentials. (I don't know why) As the User I see "Page can't be displayed". So I don't know why there is this big difference. But I'll try again your information and reply the result. But before I configured instead a CNAME a A Record and this didn't works, too. And in one tutorial there was described to use the CNAME for the whole domain as in the picture above. – Patrick Mar 5 '16 at 13:49
  • ALIAS (CNAME) is what you need. And for sure, it must be defined as a pointer to sharepoint.test.local. – Evariste Mar 5 '16 at 13:56
  • No it doesn't work :( I restarted the server but still not work. Forwarded Lookup Zones "apps.test.local". Name: "*", Type "Alias (CNAME)", Data: "sharepoint.test.local." Timestamp: "static". Hmm. And I restarted the whole server after changing. :/ – Patrick Mar 5 '16 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.