0

The SharePoint farm was built on port 80 and extended to 443. 80 is currently in the default zone with 443 in the extranet zone. I have Search crawling both zones, but when a user performs a search on the extranet zone, they get "Object reference not set to an instance of an object." If I perform a search on port 80, I get no errors.

The zones use different authentication methods, and I am not seeing any errors with the search crawl.

  • I have my environment setup exactly as yours and facing the very same issue with search.Can you kindly elaborate on your fix? – George Sep 29 '16 at 8:31
  • Ultimately never got a fix. Search only likes to work on 1 of the AAMs at a time. – MattC Sep 30 '16 at 16:26
1

You only need to crawl the default zone. Search will handle the AAM for you and change the URLs accordingly. Once you get the Alternate Access Mapping working correctly you should perform a full crawl to clear up the index. (Possibly even resetting the index.)

If you are in a single server farm you may need a loopback exception for your URLs (don't simply disable loopback, it is there for a reason). If you are in a multi-server farm configure a crawl target rather than disable loopback. If you can view the content from the crawl server in a browser while logged in as the crawl account, you should be fine. Once all that is working, then retry your crawl.

If you still get the error, check the logs. You may have a communication error with your Query server.

  • I currently have the default zones for both my web apps set to 443. When I check the crawl urls for both web apps, I am seeing successes. When I make a search using the "everything" tab, all of my results are returned with HTTPS. As soon as I move to the "People" tab, all of the results are returned with HTTP. – MattC Mar 3 '16 at 14:20
  • Are you running the My Site Host under SSL? If so are you crawling it under SSL? (sps3s://mysite) – Matthew McDermott Mar 3 '16 at 21:56
0

Did you try to change the alternate access mappings to the default zone and disable loop back?

  • This worked. However, I now get that same error when performing a search on port 80. When a search is performed on port 443, I get results. This is fine because all my users only use port 443. – MattC Mar 3 '16 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.