0

I've built a custom interface on a SharePoint Form (list-bound custom edit form created from SharePoint Designer) that relies on a block of code loaded in a Simple Form WebPart (javascript and CSS) to restyle and extend the functionality of the page. This was needed mainly because our SharePoint instance is hosted, and therefore we couldn't just knock together the correct form in Visual Studio.

For most users (I believe all users in the past) the form loads correctly, including the JavaScript and CSS, but it turned out that our users in one region weren't getting it. Looking at the HTML of the form that they were getting, there was no evidence of the webpart there at all, which led me to think it was a permissions issue of some kind - and sure enough, when I added All Site Users to the Target Audience section of the WebPart, for most people it showed up.

For some, it still doesn't. I've even tried adding groups that I know they're a member of (iterated the groups using the CSOM on their user object from their machine, so guaranteed they're there). Nothing. Can anyone give me any idea why this is happening and how to fix?

0

Could probably be a matter of Draft/Published state. The behavior is not related to the Target Audience, but to the state of the page that holds the Web Part. If the page is in a document Library with Approval set, or with minor versions enabled, some users may not have permissions to see the page if it's not in major version, while others can see it. The solution would be to check whether the page is published and approved.

Could also be your CSS/JavaScrit files being in minor/draft versions: the Web Part is there for all, but cannot load any resource files for users who cannot see the draft versions of these CSS/JavaScript.

  • Any idea how to check this? I haven't been able to find a publish button on either the list or form in SP designer, nor any indication as to what's checked out. The WebPart itself (and any styles etc) are currently embedded in the form, too, so I'd be surprised if there were issues in loading part of it if any of it loaded - it's just that no part of it appears at all... – tobriand Mar 2 '16 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.