1

I am having a picture library which has default SharePoint column Description but my users are having more than 255 characters that needs to be uploaded for description.But SharePoint is not allowing to do so.Is there any alternate to allow 255 characters in to the description column.I am using SharePoint 2010.

1

It's actually quite simple. Go to list settings, click on the description column to modify it. Now change its data type to multiline text from single line of text.

Choose the number of lines based on your requirements and you are good to go. So if you have 5 lines, you should get 256*5 characters limit.

1
  • Hi Nisarg, this is a default column in Library which don't have an option to change. As such description is by default has mutliline text as type. I want number of characters to increase which i don't see for default column. – SPLearner Feb 29 '16 at 16:07
0

I would turn on content management, hide the default description field, and add my own field called "Descrip."

6
  • But that cannot be shown in picture library slide show web part as description. I am showing this description in slideshow web part.Any other options? – SPLearner Feb 29 '16 at 16:08
  • There are a decent number of articles that say you can modify the site column (it's name is Comments, not Description) to "Allow unlimited length in document libraries." (ybbest.wordpress.com/2013/01/14/…) This didn't work for me though; I'm not sure why. I also thought perhaps I could create a copy of the picture library slideshow webpart and change the XML, but i couldn't get that to work either. – Erin L Feb 29 '16 at 16:42
  • Hi Erin I tried to modify xml but it is not reflecting the changes .. i tried in designer to set the description column to <FieldRef Name="Description" UnlimitedLengthInDocumentLibrary="TRUE" FieldType="SPFieldNote" /> but of no use. – SPLearner Feb 29 '16 at 18:24
  • Sorry, I don't have any more ideas. – Erin L Feb 29 '16 at 18:39
  • Do you have any .NET or JQuery experience? – Erin L Feb 29 '16 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.