I've installed and configured Workflow Manager 1.0 +CU3 in a standalone SharePoint 2013 farm patched to SP2 Feb2015CU.

In order to eliminate as many issues as possible, I've created a very simple SharePoint Designer workflow with 1 stage. The only action it performs is logging a message to the workflow history list.

I have a 2013 workflow associated to a list and allow it to be manually started. When I manually start it, it stays in a 'Starting' state forever.

I see the following exception being logged immediately after application authentication when I turn on verbose ULS logging:

Workflow instance 0d39e99d-b7a3-4827-af42-2c39b4c0461a is in retry state but GetRetryMessage threw exception: System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary. at System.Collections.Generic.Dictionary`2.get_Item(TKey key) at Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.GetRetryMessage(WorkflowInstance instance) at Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.GetInstance(Guid instanceId)

There were no errors during the installation/configuration of either Service Bus or Workflow Manager. I have followed the troubleshooting guides and the only thing I can see is I do get an untrusted certificate error when I browse to the :12290 address for the workflowhosturi although that is NOT the uri I used when registering the service.

Note: when I performed the Register-SPWorkflowService cmdlet this is what I entered:

Register-SPWorkflowService -SPSite 'http://mySiteCollehost/mysite' -WorkflowHostUri 'http://FQDNOfServer:12291' -AllowOauthHttp -Force

  • have you tried to add that certificate into the SharePoint central admin. central admin > securtiy > manage trust> on this page upload the certificate( workflow)
    – Waqas Sarwar MVP
    Commented Feb 26, 2016 at 16:34
  • What certificate? For the FQDN of server? During installation/configuration I opted for the Auto-Generate of the outbound signing certificates for both Service Bus and Workflow Manager which as I understand it generates several certificates in the certificate store. Are you saying I should add one of THOSE to the Manage Trusts? Commented Feb 26, 2016 at 17:28
  • On the workflow manager server, if you go to IIS and Workflow manager site and click on bindings...edit the https and view the certificate, copy that one and add into sharepoint
    – Waqas Sarwar MVP
    Commented Feb 26, 2016 at 18:32
  • Workflow Manager is installed on the SharePoint server. (This is a single server SharePoint farm) When I go to IIS, there is no certificate associated with the https workflow site (port 12290). I assumed when I selected the option to auto-generate the signing certificate during configuration that it would make that association automatically. Is this not correct? Commented Feb 26, 2016 at 19:38
  • yes, it should be. i think that is your problem...i would uninstall and reinstall the wf manager
    – Waqas Sarwar MVP
    Commented Feb 26, 2016 at 19:40

1 Answer 1


Getting SharePoint Hosted Apps with Workflows to work with self-signed wildcard certificates http://www.xenox.net/2015/03/25/getting-sharepoint-hosted-apps-with-workflows-to-work-with-self-signed-wildcard-certificates/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.