2

I am getting below error while deploying solution.

In Central Admin

Some of the files failed to copy during deployment of the solution.

In ULS

Solution Deployment : Error occurred for solution solution.wsp - Error: The copying of this file failed: Telerik.Web.Design.dll.

I am getting simile error for other third party dll as well.

2

there are couple of reasons for this error.

  • if you have antivirus installed on the server, then make sure it is not blocking those dll to deploy.
  • make sure SharePoint timer and Admin services running on all servers
  • May be restart the time service and admin service on all sever, some time timer service lock the files on the server.
  • also check if you package files are not locked at all.
  • Thanks a lot for your help. But none of the solution worked for me. If i delete files from web application's bin folder before deployment it worked. If file is present then it throws this exception. Also this exception is not being thrown on all machine. I could not understand how can i check "package files are not locked at all" – Ravi Khambhati Feb 28 '16 at 15:39
  • r u deploying via powershell then can use force parameter...riight click on the files see the properties n see if it is locked...also recyle timer service on that server? – Waqas Sarwar MVP Feb 29 '16 at 2:55
  • I am using Force parameter as well as I am restarting timer service before installing solution. Sorry but I couldn't find anything which says Lock in property window of DLL. – Ravi Khambhati Feb 29 '16 at 15:30
  • what you doing, upgrade the service or reInstall it? are the Dlls also aviable on other servers? – Waqas Sarwar MVP Feb 29 '16 at 15:31
  • 1
    after removing the files still exist in the bin folder, right> – Waqas Sarwar MVP Feb 29 '16 at 18:18
0

Try stopping IIS and the Timer service on all servers before deploying: iisreset /stop net stop sptimerv4

Then reverse after: iisreset /start net start sptimerv4

Those are the two most likely EXEs that will lock the Telerik DLLs. The SharePoint install process should clear the locks for w3wp.exe at least, but in practice we have seen that sometimes it doesn't. This seems more common when the DLL is a dependency for the primary WSP output. Not sure why, just an observation.

  • Which version of SharePoint it is ? – Achiever SP Feb 6 '18 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.