3

I have a method which checks valid session which gets triggered in page load,I have placed break points in it for debugging purpose.When I run my provider hosted sharepoint app it does not hit the method.

The debug break-point shows

The breakpoint will not currently be hit. No symbols have been loaded for this document

Before posting this question,I referred many posts where some solutions where given including, 1.Enable <compilation debug="true" /> in web.config file.

2.Do Enable just my code in VS. and few others.

What can be done to enable debugging the method?

  • Are you trying to debug C# or JavaScript? Are you in IE or Chrome? You cannot debug JavaScript in Visual Studio if you are not using IE. – wjervis Feb 25 '16 at 13:56
  • c# code and Used IE.The issue is resolved.Thanks for your response anyway. – kaarthick raman Feb 26 '16 at 9:33
8

Right click on your solution -> Select Set Startup Projects -> Choose Multiple Startup Projects -> and select Start action for both app and app web projects. Also, app web project should be the first one.

This should do the trick.

  • Yeah it did! Thnks a lot – kaarthick raman Feb 25 '16 at 11:29
  • great. Please mark it as answer. – Garima Feb 26 '16 at 4:12
  • 1
    Unfortunately @kaarthickraman hasn't been seen since november 2016, but hopefully he will come back to accept the answer. +1 – Benny Skogberg Nov 2 '17 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.