I published a major version of a custom page layout in SP Designer 2010 and it popped up a box asking “This document requires content approval. Do you want to view or modify its approval status?” When I clicked yes, it opened the Opera browser for some reason, even though that's not my default browser -- IE is.

I closed the browser and uninstalled Opera, then tried publishing a major version again. This time, it popped up again about the approval status, but then didn't do anything when I said yes. Did I break something in Designer? How do I have it bring up the approval status in IE? Thanks.

2 Answers 2


If you go to the library that holds your file(s), you should have an Approve/Reject view you can use to view the item(s) needing approval and approve them. Or you can just find the item in the library and approve it. Clicking on the tick box by the item should expose a option to Approve/Reject in the UI.

You might want to try repairing Office and checking/resetting the default programs to ensure IE is being recognized as the default.


Thanks Pirate Eric, had the same problem and it worked for me! Checked the site, went to the drop down to view properties and there is a second "Approve/reject Item" link there. I had to go here in order to make it work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.