I've got some existing lists that have custom content types inherited from the Document content type. I've activated the Document ID Service feature, and any new lists I create using the same content type are working just fine.

But it's the items in existing lists that won't take the Document ID. Other things I've tried:

  • Running the Document ID Assignment job

  • Ran Gary Lapointe's propagate Content Type command:


which after adding some debugging I'm seeing that when searching for the Content Type in use:

IList<SPContentTypeUsage> ctUsageList = SPContentTypeUsage.GetUsages(sourceCT);

I'm getting a count of 0, although every item in the list is set to that Content Type.

Anyone seen anything like this or run into similar issues?


4 Answers 4


Remember the Limitations

ONLY content types that are derived from the Document Content Type will have unique ID’s enabled, no list items will get id’s assigned :evil:


It seems to take a long time for existing documents to get Document IDs after you enable them, even allowing for the daily nature of the timer jobs.

I have also found that if I run both the Document Enable/Disable and Document ID Assignment jobs for all the web applications that it seems to create the Document IDs on existing documents. I can't remember which category I did first, probably Enable/Disable. This is just from experience, and could have been entirely coincidental. But it might be worth trying.


I ran into a similar problem and found activating/deactivating the feature in Site Administration worked for me: Site Actions > Site Settings > Site Collection Administration > Site collection Features > Document ID Service


I didn't find the root cause, but I found a quick fix.

  1. Create a new content type from the “Document” type.
  2. Add the columns from the original Content Type to the new one
  3. Add the new content type to the list
  4. Remove the old content type

As soon as you upload a document using the new content type you will get a doc ID.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.