0

I have a very strange issue: Two files (excel files) - each belonging to a different document set - are shown within the top level view when using a specific Key Filter setting which should only be relevant to the document sets in my library.

Document Library Settings (Content Types)

Simplified, I have a document library with the following two content types

  • Basic Document Set
    • Content Type: Derived from "Document Set"
    • Column "Relevance Status"
      • Type: Managed Metadata (points to a very small and flat taxonomy: {Active, Historical})
  • Basic Document
    • Content Type: Derived from "Document"

Document Library Content

Based on the above content types, my document library looks as following:

DocumentationA
DocumentationA/FileA.xlsx
DocumentationB
DocumentationB/FileB.xlsx
  • DocumentationA and DocumentationB are both document sets of type "Basic Document Set"
  • FileA.xlsx and FileB.xlsx are both documents of type "Basic Document"
  • DocumentationA has a "Relevance Status" set to "Historical"
  • DocumentationB has a "Relevance Status" set to "Active"

Metadata Navigation Settings

Since I want to hide/show certain document sets using the "Relevance Status" , I have configured this field as "Key Filter Field" with an automatic index creation.

Issue: Filtering shows unrelated files

When I filter the documents using the "Relevance Status" "Historical", only the document set DocumentationA appears: This is fine and what I expect BUT when I filter the documents using the "Relevance Status" "Active", the document set DocumentationB AS WELL AS both excel files FileA.xlsx and FileB.xlsx appear. Why?

I cannot see any connection between these files and document sets. Clearly the documents don't have this column I am filtering. BTW: The view settings in Folder are set to Show items inside folders.

  • I guess that you have double checked that the Relevance Status for FileA.xlsx has not been changed to Active? Even if the status is Historical on the document set, the value for the documents in the Doc set can be changed to something else. – Jenny Fergéus Feb 24 '16 at 14:28
  • Well, that's the strange thing: The content type of my documents does not even have this column. That's what makes me worried... – tschaena Feb 24 '16 at 15:46
0

The IT department was able to solve my issue with some kind of a workaround:

Removing a default value from the site column avoids triggering this issue.

I was told that the documents inherit the default value of the document set as hidden properties even if they don't have the property defined.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.