For SharePoint 2013 I have two accounts, my primary system logon and my administration logon. When accessing https://spadmin.internal.domain/ with IE11 the SSO automatically tries to logon using my primary system logon which fails throwing a message of 'Sorry, this site hasn't been shared with you'. There is nothing else on the page.

How can I logon using my admin account when it doesn't ask for my username and password and does not have an option to switch user?


Open IE11 and follow below steps:

  1. Go to Tools >> Internet Options(last option) >> Security tab(2nd tab) >> click Custom level button.
  2. Scroll down in Settings pane.
  3. In the end, there is User Authentication logon, select Prompt for user name and password.
  4. Click OK button. (Do it in both windows)
  5. Restart IE11.

And then try to access your url.

Hope this will help you.

  • Also: added website to Internet Options > Trusted Sites and set this to Prompt to username and password and it worked. Unsure how this is different to using closeConnection.aspx or run as. This solves the first problem allowing for identifying the other issues. – Underverse Feb 23 '16 at 22:55

There are two workaround for this problem.

  1. Start Internet Explorer or other browser by using the Run as different user option and use your admin account as login.
  2. Access the SharePoint site by using the following URL:


  • Tried #1 - did not work. Same error. It did allow for logging in as the alternate account. Tried #2 - Opened new IE11 window, SSO automatically logged in with LAN account, changed to a URL with _layouts, set URL to _layouts/closeConnection.aspx?loginasanotheruser=true and it asked for a new logon name and password. Entered admin account username and password and saw the same error. Alternatively, I used Google Chrome with the spadmin url. It asked for a username and password and works. IE11? Internal settings or configuration? Mutual distrust of Microsoft products? – Underverse Feb 22 '16 at 3:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.