I've been trying for about 3 days to restore a SharePoint backup to my local machine to set up a development environment (running SharePoint Foundation 2010). I'm struggling with the following error:

Your backup is from a different version of Microsoft SharePoint Foundation and cannot be restored to a server running the current version. The backup file should be restored to a server with version '' or later.

Both machines (production and local) are running SharePoint Foundation 2010. I've verified that the patches on the production machine are applied to this machine, but I absolutely cannot get passed this error. PLEASE help! This is the command I'm running:

Restore-SPSite http://mymachine/ -Path C:\Backup\Live.bak -Force
  • If you plan on down voting the question, please explain why or try to offer some kind of help. People use this forum for guidance and help, and drive-by down voting with no explanation offers neither.
    – Christine
    Feb 19, 2016 at 20:24
  • Update: I ran Update-SPContentDatabase and then tried rerunning the restore. It hasn't errored, but boy is it CHUGGING!!! The .bak is 22 gigs. How long is this gonna take? Good lord!
    – Christine
    Feb 19, 2016 at 20:34
  • empty recycle bin to reduce the site backup.
    – Ankur
    Feb 20, 2016 at 8:56
  • It seems that the config versions are different in both the farms,First check the patch level of your source and destination environment. Make sure your destination environment is not at lower version than the source. If so , you may need to patch your environment as same as your source. There are cumulative updates from microsoft. So make sure both the environment having same update and version.
    – Ankur
    Feb 20, 2016 at 8:57
  • If the issues that was blocking you was indeed that you didn't run Update-SPContentDatabase before and as such the database were still in a "need to apply updates" status, you could add that as a reply? That way the question can be set as answered.
    – SPArcheon
    Feb 22, 2016 at 20:00

1 Answer 1


The problem was that I need to run Update-SPContentDatabase on the content database being used.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.