12

I am facing a problem in Web/Lists/GetByTitle method. By default, it returns only 100 rows.

I changed it to http://sitename/_api/Web/Lists/GetByTitle('list')/Items?$top=300.

When I hit this URL into the browser, I am getting all records but when I put this in the workflow as a step, it fails.

Can anybody please let me know what else I need to change to make it work in the workflow as well.

  • 1
    Log the error message and see the error details – Atish Dipongkor - MVP Feb 15 '16 at 11:25
  • 2
    Refer Get more SP items using REST. It talks about the same issue – Ram Yadlapalli Feb 15 '16 at 18:01
  • which property u want to get from all those items?? – Melad Batta Aug 23 '16 at 6:53
  • Ideally these REST URLs are supposed to work. Mostly Workflows will be focusing an item than items. So for what you are fetching huge number of item? – Vishnu PS Feb 15 '17 at 6:44
  • I am getting the same issue, did u resolved? pls suggest – Vishwanath Mishra Jun 27 '18 at 7:52
1

Used top filter to get data

Example:

/_api/web/lists/getbytitle('listName')/items?$top=1000   //returns only 1000 records
0

I am thinking it might be a response size issue. Can you please try to limit the records to 10 and see if it works. I can help you reading all records in chunks if limited number is working. or You can log error by data/responseText.

0

The limit is due to server-driven paging. It protects against developers inadvertently making a request that returns large result sets. Hence by default it will return only 100 items until you explicitly specify number of items to be returned.

0

The sharepoint rest apis by default returns 100 rows per query if you haven't provided any $top parameter.

you can overcome this problem by

  1. recursive rest api calls.

  2. using $top parameter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.