0

Having gone thru the process of installing Apps, I seem to be stuck with some sort of missing pre-requisite that I cant get my head around.

I have installed and configured App's, I can browse the App store and I can download one or two apps. For the majority of App's though they are all greyed out. When I click on them I see a message saying

"Sorry this App cannot be installed on your server"

When I look at the ULS log, I see an error for a failed pre-requisite when loading the add,

Prerequisites Checking for App 'K2 blackpearl for SharePoint' failed: Service capability with name='Azure Access Control Service Application Proxy' is not available. Service capability with name='Windows Azure Active Directory Service Application Proxy or SharePoint Online Application Principal Management Service Application Proxy' is not available.

Prerequisites Checking for App 'Actionspace for SharePoint & Office 365' failed: Service capability with name='Azure Access Control Service Application Proxy' is not available. Service capability with name='Windows Azure Active Directory Service Application Proxy or SharePoint Online Application Principal Management Service Application Proxy' is not available.

Not really sure how "Azure Access Control" fits into it all, this is an on-premise install of SharePoint 2013. The error in ULS is the same regardless of the App.

0

Did you add this app from the Sharepoint App Store? If so i think there's a dependency on the version of the K2 Blackpearl Server.

Alternatively, have you tried uploading a full control K2 for Sharepoint app into your Sharepoint App Catalog?

http://help.k2.com/kb001443

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.