1

I am developing custom SharePoint MasterPage page.

The issue is that Top Navigation snippet does not show publishing pages links in my custom MasterPage whereas default Seattle master page does shows it.

Take a look at Navigation Settings, also notice Pages are listed on top navigation by default Master page: enter image description here

Custom Master page, shows only two items and does not include publishing pages: enter image description here

Top Navigation do shows pages in preview mode: enter image description here

  • Check if your SiteMapProvider in your custom master page is "SPNavigationProvider" or not. Are the pages published? – Aveenav Feb 14 '16 at 23:59
  • Yes it was SPNavigationProvider. Now I realized pages need to be published to to appear in navigation, event it applies to Admin. Thanks for pointing. Please propose your answer as solution and mark it. – Amit Bhagat Feb 15 '16 at 4:28
1

The page needs to be published to show up in the navigation.

P.S: Sometimes, undo(ing) and redo(ing) the Show pages checkbox also makes it work.

  • In my case the page was newly created and never checked in or published. So I guess at least one published version is required to appear in navigation. – Amit Bhagat Feb 18 '16 at 7:51
  • I Published the pages. However still not showing. Am i missing some thing. Mine too is a custom master page. – shoab Oct 30 '18 at 5:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.