I have a SharePoint list holding 9500 records. I have created about 9 views so that I overcome the 5000 threshold limit. To create these views I have indexed certain columns on which I have applied the view filter. But in one of the views where the record limit is the maximum (3900), after filtering system gives an error the view threshold is reached when the field filters are tried to use. Please suggest if there is some solution to this other than increasing the threshold.

  • I know it is an old post... But did you ever resolved this? Have the same issue.
    – M.P.
    Commented Nov 22, 2019 at 14:23
  • Why don't you remove the threshold limit?
    – Emaborsa
    Commented Mar 5, 2020 at 18:50
  • Have you tried to limit the number of item showing in a view?
    – Billy P
    Commented Sep 16, 2020 at 18:25

2 Answers 2


You mentioned that you have indexed the columns, but it still sounds to me like an indexing issue. I would double check that column you are filtering on is indeed indexed. From this article:

The threshold limit error message shown above could even pop-up when attempting to load items from a view that doesn’t even display more than 5000 items. How come? Well this is mostly due to the fact there’s a filter on a non-indexed column. For instance let’s say you have a view called “Recently modified” that shows all items that have been modified since last week, but the “Modified” column is not indexed. In that case, SharePoint will have to load each single item in order to filter which ones fit the filter criteria and which ones don’t. Eventually, even if there are less than 5000 items modified since last week, you might still encounter the error mentioned above, if the list itself contains more than 5000 items.

Are any of your columns a lookup column by any chance? If so, this might be relevant to you.

  • Hi Ray, Thanks for the reply, but none of my columns are lookup and i have double checked with the filter column being indexed but still facing the same issue. Commented Feb 12, 2016 at 14:25
  • My other views are using the same indexed column to filter out the data and are working perfectly fine but just this one with 3900 items is posing an error. The error appears only when i try to use the page field filters. I am able to sort the fields but not filter them and that too in a single view. Commented Feb 12, 2016 at 14:30
  • Are any columns used for filtering date fields?
    – Erin L
    Commented Feb 12, 2016 at 14:31
  • Hi Erin, there are no date fields Commented Feb 12, 2016 at 14:34

I had faced a similar issue and the only option without increasing the threshold was to add more filters or update filter criteria in the view and ensure that the first filter field of the view is indexed.It doesn't matter if the 2nd or subsequent filter fields are indexed or not. This is because the threshold limit is not based on the number of results returned by the view rather it is dependent on number records scanned at the database(table) level. So, if the first filter criteria itself returns more records than the threshold the SQL query engine has to scan all the records which will throw threshold exceed exception.

  • Hello shridhark, I have made sure that the mentioned pointers have been taken care of, but still the same error persists. Commented Feb 15, 2016 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.