I am trying to upgrade Sharepoint server 2007 (Enterprise CALs) to SP2010. I'm using the SP2010 evaluation package from Microsoft along with the included license keys.

When the upgrade process starts I'm prompted for the licence key, I paste it in, the key gets validated fine. However, on the next screen of the upgrade wizard I get an error message: "A previous installation has been detected with a license type does not match the install in progress".

I can't proceed past this point. I've googled the error but there is not much out there.

Any ideas?

Regards, Greg


3 Answers 3


You are most likely getting hung up on a registry entry. You should be able to remove that entry and continue your installation. To get it, use process monitor during your attempted install and you can see which keys it is pulling up. I've linked a previous question that had a similar issue.

  • Thanks for the tip! Have tried the approach but even with filtering the amount of registry keys queried is just too huge to go through. Well, if I knew what I'm looking for that would be different. I think a registry key that pops up is HKLM\SOFTWARE\Microsoft\Office\12.0\Registration - however, I won't risk deleting it just to test whether the upgrade goes through. Is it possible that the upgrade is failing because running an upgrade of a non-trial Sharepoint install with trial SP2010 package is not supported (different versions)? Jul 29, 2011 at 14:50
  • I've upgraded production DB's on trial install for testing via DB attach with no issue, but have not tried an in-place upgrade. It may indeed be an issue with the upgrade path. The key you are using is the Enterprise key correct (not Internet or Standard)? Also you can export a key, or just backup the entire registry before making the change so it is easy enough to restore. I assumed this is "test" machine and not production based on what you are trying to do. Also SPD is a part of office family and installs shared office items. Try uninstalling SPD as @naijacoder suggested. Jul 29, 2011 at 15:05
  • I've deleted the HKLM\SOFTWARE\Microsoft\Office\12.0\Registration key, restarted the installer and it kicked in without problems. The installation has just completed! This is a test server so I don't mind messing with the registry but obviously this wouldn't be the best idea for a production server. Thanks for the process monitor tip! Jul 29, 2011 at 15:42
  • Wow - I had the same exact problem trying to get the install started and deleting that registration key worked for me! Thanks so much for the help!
    – user10943
    Sep 25, 2012 at 17:15

I've only seen this error twice (...at the same customer) and the customer had two problems that was causing it: First, they had the wrong license...they were trying to upgrade from 2007 with Enterprise CALs to 2010 Standard. They fixed that and were still getting the this error...this time it turned out that they had not installed SP2007 SP2. Once they did that they were able to upgrade to SP2010.

If you haven't already, you may want to run the pre-upgrade checker to see if it reports anything else that may be causing a probvlem: http://technet.microsoft.com/en-us/library/cc262231.aspx

  • The CALs were ok in my case, and SP2 was installed. Pre-upgrade checker didn't report anything either. Thanks for the tips though. Jul 29, 2011 at 15:43

Do you have Office install on that box? e.g Project etc.. You might have to uninstall

  • No, no Office installed apart from SPD 2007 Jul 29, 2011 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.