1

When i try to add a link to the top nav bar, I am doing this from the cms so not from code. I get the security validation invalid error. http://img233.imageshack.us/img233/5761/errorcs.png

On the internet, i can find lots of reasons why this error can occur when using your own code. The thing is that i am not using any custom code.

The only thing i use is a custom master page. When i set the site to use the standard master page i do not get the error. So obviously the error is in the master page. So my question is:

Has anyone had this problem before?

Does anyone know the solution to my problem?

Any help is appreciated.

Note : This question is still not answered

Error:

07/29/2011 11:13:54.89 w3wp.exe (0x0EAC) 0x098C SharePoint Foundation Runtime tkau Unexpected

System.Runtime.InteropServices.COMException: The security validation for this page is invalid. Click Back in your Web browser, refresh the page, and try your operation again. at Microsoft.SharePoint.Library.SPRequestInternalClass.AddNavigationNode(String bstrUrl, String bstrName, String bstrNodeUrl, Int32 lType, Int32 lParentId, Int32 lPreviousSiblingId, Boolean bAddToQuickLaunch, String& pbstrDateModified) at Microsoft.SharePoint.Library.SPRequest.AddNavigationNode(String bstrUrl, String bstrName, String bstrNodeUrl, Int32 lType, Int32 lParentId, Int32 lPreviousSiblingId, Boolean bAddToQuickLaunch, String& pbstrDateModified)

1

Can you check to see if you've included this in your masterpage?

<asp:ContentPlaceHolder id="PlaceHolderFormDigest" runat="server">
    <SharePoint:FormDigest runat="server"/>
</asp:ContentPlaceHolder>

Also, Randy Drisgill has some start master pages available on Codeplex that you can use. It has all the required content place holders on it to ensure your site functions normally.

  • Thanks, i do have this contentplaceholder. I used the basic master page that Randy Drisgill provided. To be certain i will recheck all placeholders. Thanks for the input – nldev Jul 28 '11 at 14:50
  • i looked over every starter page and checked every content place holder and i have them all, any other suggestions? – nldev Jul 29 '11 at 7:42
  • do you see anything in the ULS logs with that correlation ID? – Eric Alexander Jul 29 '11 at 12:05
  • yes, i added it to the main question – nldev Aug 1 '11 at 9:33
  • Joel just blogged about some security validation stuff, perhaps that's what your running into, sharepointjoel.com/Lists/Posts/Post.aspx?ID=470 – Eric Alexander Aug 1 '11 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.