2

I am running in a VM that is using Windows 2012 R2 and Sharepoint 2013 installed.

When I create a Office add-in that is empty. Or when I use one that is pre-defined like the examples in here.

I am getting the same error:

APP ERROR Sorry, we can't load the app. Please make sure you have network and/or Internet connectivity. Click "Retry" once you're back online.

enter image description here

The localhost web is accessible without problem. The web application is using IIS Express. Should I configure something on VM or IE options ? Already updated the Office 2013 to use the SP1.

  • Are you trying to add App from Windows Store? Are you able to browse internet from your VM? – Thirusanguraja Venkatesan Feb 8 '16 at 13:01
  • Could you provide more details on which approach you choose from the mentioned post? – Unnie Feb 11 '16 at 21:53
  • @ThirusangurajaVenkatesan No, Yes. – Tito Feb 15 '16 at 10:48
2
+50

Not sure if you understand the architecture of these addins, but it might help you troubleshooting the issue.

An office add-in is in basic a web page that is hosted in a sort of Iframe in the office application. So when you run the sample it spins up a local iis to host the site en load in the office client. For developing you don't need internet access, but it looks like the client could not connect to the website in the background. Or the website in the background is not started properly.

To be more specific you need to configure somethings described in here, some of those configurations consists on:

  1. Make sure the security setting, Display mixed content, for the Internet zone is set to Prompt.
  2. Make sure Warn if Changing between Secure and not secure mode is selected in the Advanced tab of the Internet Options dialog box.
  3. When hosting the app use always the IIS, create a directory, instead of using the IIS Express and run it using SSL.
  • Agreed. This error will also display if the webserver returns a HTTP/500. – Boland Feb 10 '16 at 23:24
  • 1
    I complemented you answer, bullet 3 was my problem. I should use the IIS and create a directory, instead of using IIS Express. Once you accept the edit I will accept your answer. :) – Tito Feb 15 '16 at 10:48
  • Nr 2 was the problem for us. – Fox May 30 '16 at 4:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.