2

Using the URL, users are able to authenticate and access our root site but the Nav Bar menu and side menu do not display. They just display "Error". However if a user access the site using the server name as the address instead of the URL the menus display. What could the permission problem be?

Here is the start of the error from the ULS log:

System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)), StackTrace: at Microsoft.SharePoint.SPWeb.get_AllProperties() at Microsoft.SharePoint.Publishing.CacheProfile.<>c__DisplayClass4.b__0() at Microsoft.SharePoint.SPSecurity.<>c__DisplayClass5.b__3() at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode)

0

Is your website URL added in Alternate access mapping?

To manage alternate access mapping:

  1. On the SharePoint Central Administration website, click System Settings.
  2. On the System Settings page, in the Farm Management section, click Configure alternate access mappings.

For more information, you can check below link: https://technet.microsoft.com/en-in/library/cc263208.aspx

  • Yes, alternate access mappings are set up. Also, there are some pages where I can see the menu. For example, if I go to the main page for the Finance or IT departments I can see the left menu but if I go to the HR department I get the access denied error on the left menu. – user1074426 Feb 4 '16 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.