Im trying to fix a degraded index, using the script from this post. How do I fix a degraded SharePoint 2013 index partition when there is only one of them?

But the last line Set-SPEnterpriseSearchTopology -identity $clone, resultes in this error:

Set-SPEnterpriseSearchTopology : Topology activation failed. Management called failed with System.InvalidOperationExcep
tion: 'Unable to change topology when Generation controller is not active' at    at Microsoft.Ceres.SearchCore.IndexCon
troller.IndexController.IsEmptyIndex(String indexSystemName)
   at Microsoft.Ceres.SearchCore.IndexController.IndexControllerManagementAgent.WrapCall[T](Func`2 original)
At E:\recreatesearch.ps1:27 char:1
+ Set-SPEnterpriseSearchTopology -identity $clone
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidData: (Microsoft.Offic...tSearchTopology:SetSearchTopology) [Set-SPEnterpriseSear
   chTopology], SearchTopologyActivationException
    + FullyQualifiedErrorId : Microsoft.Office.Server.Search.Cmdlet.SetSearchTopology

This means i'm not able to fix the degraded index. And im left with the option of resetting the index. I would like to avoid this by any chance, because its estimated to take 4-5 weeks to complete.

Do anyone have any tricks i might try.

I already tried: reset confic cache, restart search host, restart search server, reboot the server itself.

  • Is any of the search components down/degraded? And do you have a link to the post that you mention? Commented Feb 3, 2016 at 15:55
  • I added link to the post. just as in the post (How do I fix a degraded...) the indexComponent is degraded. I create a clone and replace the index component with a new one. But unlike the post, my Set-SPEnterpriseSearchTopology -identity $clone call failes with the mentioned error. Commented Feb 3, 2016 at 15:58
  • Did you ever resolve this? Commented Feb 12, 2016 at 16:05

1 Answer 1


I think that you won't be able to avoid an index reset or a re-crawl.

I'm not a search expert and have only cloned a search topology once but it seem's that all the search components need to be in a healthy state to be able to clone them, otherwise you would only clone a topology that is still broken and would be stuck with the same problem.

SharePoint 2013 Unable to change topology when Generation controller is not active

If you had multiple topologys where you had at least one component that were healthy, it could have been possible to clone that one.

Here's a thread where a member of this forum tried this, sadly without success so he had to recreate the search service application from scratch.

Create new Index Component and add it to a clone topology?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.