0

UserProfileApplication.SynchronizeMIIS: Failed to configure ILM, will attempt during next rerun. Exception: System.FormatException: Index (zero based) must be greater than or equal to zero and less than the size of the argument list. at System.Text.StringBuilder.AppendFormatHelper(IFormatProvider provider, String format, ParamsArray args) at System.String.FormatHelper(IFormatProvider provider, String format, ParamsArray args) at System.String.Format(IFormatProvider provider, String format, Object[] args) at Microsoft.Office.Server.Administration.ProfileSynchronizationServiceInstance.IsStarted(ServiceController controller) at Microsoft.Office.Server.Administration.ProfileSynchronizationServiceInstance.WaitUntilStarted() at Microsoft.Office.Server.Administration.UserProfileApplication.SetupSynchronizationService(ProfileSynchronizationServiceInstance profileSyncInstance).


I've tried changing the registry for FIM, DependOnService but that suggestion didnt work out for me.

Any ideas?

  • did you see any dependency? right click on the FIM service and under dependenc tab see if their is any listed? – Waqas Sarwar MVP Feb 1 '16 at 16:23
  • also login with Farm admin acocunt on the SYnc server and make sure following url will be accessable...crl.microsoft.com ctldl.windowsupdate.com ctldl.windowsupdate.nsatc.net www.update.microsoft.com.nsatc.net – Waqas Sarwar MVP Feb 1 '16 at 16:26
  • @WaqasSarwarMCSE what if the server do not have Internet access? Is there any workaround? – Mark L Dec 7 '16 at 3:40
1

I got it fixed.

When starting the UPAS the FIM tried to check the firewall ports.
I looked inside my Windows Firewall and saw that the service had created 25-30 firewall rules.
ILM Web Service - RMS and the ILM Web Service -STS.

I deleted all the rules and started the User Profile Sync, the FIM created two new rules and the the service started.

I dont know who to mark this question as answerd but here it goes :)

0

Have you removed the key from the registry rather than modifying it? Try removing the key completely and provisioning again.

Also, does the farm account have internet access from the server? If not, can this be provided for the startup of the service?

Obviously it's worth exporting that portion of the registry before removing the key just in case you decide you need it later!

Andy

  • I have tried removing it, I have tried editing it. The farm account got internet access. I can access Google and Microsofts site. – Elinho Feb 1 '16 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.