I have a document library list that went over 5000 items, which is my List View Threshhold limit (Under Central Admin, website, general settings, Resource Throttling). I also have several views on my list. A few of my views use filters to limit the items in the list to only 40 or so items, but I still receive the "The number of items in this list exceeds the list view threshold, which is 5000 items" error, even though the list View is well within the limit.

I've follow the advice to ensure I have indexed columns, and filters but I'm still getting this error. Any further advice you can offer?

I'm looking for a solution that does not include increasing my List View Threshold.

  • One of the most unanswered question Threshold...:(
    – Ankur
    Commented Jan 28, 2016 at 19:19
  • Filter will be applied to all items if you have not applied Indexing........................
    – Ankur
    Commented Jan 28, 2016 at 19:20
  • Thanks. I didn't have ALL of my filters indexed. I'll give that a try!
    – Maureen
    Commented Jan 28, 2016 at 19:31
  • @Maureen how many columns do the views have?
    – Citizen SP
    Commented Jan 28, 2016 at 19:32
  • 1
    To add to @Ankur comment, the first filter in the list of filters on a View must return <5000 items.
    – user6024
    Commented Jan 28, 2016 at 19:52

3 Answers 3


The first filter of a View must return less than the set List View Threshold, otherwise it will trip the LVT exceeded message.

  • This was the key. Ensuring the FIRST filter returns less than the List View Threshold. Thanks Trevor!
    – Maureen
    Commented Mar 9, 2016 at 18:52

I know that you've mentioned that your solution should not involve increasing the list view threshold, however you can do this on a list-by-list basis if required (assuming your SharePoint in on-premises) using PowerShell.

The PowerShell to do this is:

$web = Get-SPWeb http://WebURL.domain.com
$list = $web.Lists["ListName"]
$list.EnableThrottling = $false

Note that the "ListName" is the name of the list as it appears within the UI, not the URL.

To determine whether the list has throttling enabled and whether is actually throttled, use:


And to return the list to the default throttling set within Central Administration, use:

$list.EnableThrottling = $true
  • Thanks Robert. This is very useful. I may use it in future. Waiting on Trevor Seward to add his comment as an answer as that was the fix that allows me to stay within the 5000.
    – Maureen
    Commented Jan 30, 2016 at 7:05

If this is an on-premise solution you can increase the list view threshold by going to:

Central Admin -> Manage Web Applications -> select the web application you want to modify -> general settings -> select resource throttling (drop down). In the form you have a field called List View Threshold, here you can increase the threshold limit.

Increasing the limit will affect the performance, and it is not recommended to do so, get to know the consequences of increasing the limit. I have done this once (limit to 10 000) with some lower performance, so it worked fine in my case.

If this is a lookup issue you can overcome this problem with queries where the returned result is lower than 5000. For example if you have a custom form where you use select2 on a field, and the options is set by the returned result from the query.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.