1

I have a User Profile Service and User Profile Synchronization Service. This is what I did. I went into powershell and

typed: get-spserviceinstance and I got all the services status. The next step was I typed: Stop-SpServiceInstance and this stopped the service for my user profile synchronization. The last step I did was went into central administration and under manage services on services. Click on start for user profile synchronization service and it asked for the password and after which it is showing the status as starting and it is struct for long time and the same moment i start getting tons of errors and when i look into the services.msc and see Forefront Identity Manager and Synchronization is was not started even after i started that the services is not starting but the error got reduced.

Can anyone please help with this crazy problem.

Thanks Mohammed

0

Are you performing this action using a farm account? User profile sync will only start using a farm account.

  • I am doing this in my computer since I have Full Control. I do not see Manage Services on server in central administration at my farm computer? Is that right? – Mohammed Eliyas Ahmed Jan 28 '16 at 17:12
  • In Central Administration go to System Settings > Manage Services on Server Make sure "User Profile Service' is started before attempting to Start "User Profile Synchronisation Service". This MUST be done while logged in using a FARM account. – Marc Jan 28 '16 at 17:25
  • But in my Farm Computer Under System Settings I only see this Manage Servers in this Farm – Mohammed Eliyas Ahmed Jan 28 '16 at 17:34
  • Whereas in my own login I see Manage Services on Server and User Profile Service status is Started – Mohammed Eliyas Ahmed Jan 28 '16 at 17:36
  • If you go to Central Administration under 'Security' select Configure service accounts. In the first dropdown select Farm and ensure the account it is using for Farm is the account that you are using. – Marc Jan 28 '16 at 17:54
0

I come across this situation recently. User profile service can give lot of headache from different angles.

Stop the UPS services again using powershell and login to the server using the SP_FARM account. Now go to ** Manage Services on the server** and start the "User Profile Services". Now wait for 5 minutes and check the services will be running.

  • But this is what I have been doing with no luck. One difference what I see is " In my Farm account I do not see Manage Services on Server" but on my regular computer when I go to Central administration I see Manage Services on server does it a reason why it is not starting – Mohammed Eliyas Ahmed Jan 28 '16 at 17:25
  • Are you using same browser in both environment? In your Desktop PC, are you using the farm account or different service accounts? – Sathiya Jan 29 '16 at 9:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.