0

Within a document library, I have over 200 word documents created by project managers. I also have a SP title column value associated to each Word document in this library.

The problem is that on my search results page, SharePoint is ignoring the SP title column value associated to each Word document. Instead it is pulling the header region text from each Word Document as the title of the page.

How can I tell SharePoint to stop pulling the headers of each Word document, and simply relay on the SP title column value?

The funny thing is that SharePoint is doing this automatically with Word Documents, but not from PDFs. With my PDFs, if I put in a SP Title column value, it shows up in my search results. This must be a Microsoft thing...

Thanks for any advice.

  • I think this may have been answered here: sharepoint.stackexchange.com/questions/131773/… – Mike Lutge Jan 28 '16 at 1:53
  • Mike I dont have server side access to install components like that explained in that posting. If you happen to know of a display template workaround, I'll buy you lunch man! – klewis Jan 28 '16 at 2:24
1

Ideally you would do the following in Central Admin's Search Schema page if you want this change to apply to all the site collections. But if you don't have access to CA or only need to do this in one site collection then you can try just doing the following:

Go into your root site collections's site settings page and then under the "Site Collection Administration" group click the Search Schema link.

In the Managed Property filter textbox type "Title" and hit enter.

In the results click the managed property called "Title". This will bring up the properties for this managed property and you should see a "Mappings to crawled properties" section.

I'm guessing that the MetadataExtractorTitle is at or near the top. You can select it and move it down, probably below the "Title" crawled property.

Click OK to save. Then run at least an incremental crawl if not a full crawl. Or just wait until the next scheduled crawl runs if you don't have access to CA.

Hope that helps.

| improve this answer | |
  • +1 Mike for the clear instructions. But for some reason, even after a full crawl, adjusting the title properties as you mentioned, is still referencing the first word in my Word documents. – klewis Feb 9 '16 at 14:55
0

I ended up not depending on SharePoints title column because of word document issues still popping up. I instead created a new column for document titles I want displayed in search results, and told the proper display template to display that column value as title for each result.

This approach gave me an opportunity to learn more about display templates in sharepoint, and how to customize the meta data and ctx variables associated to them.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.