5

I have a list that exceeds the 5000 item limit. I created a view that is limited to 500 total items returned but I still get the error:

The attempted operation is prohibited because it exceeds the list view threshold enforced by the administrator.

There are no lookup columns on this view. What could be the cause of the threshold being tripped?

7

If you're not performing a filter within a View on an indexed column, you may receive this error. In addition, if you're attempting to use multiple filters, the first filter must return <5K results before moving onto additional filters.

  • I didn't realize this applied to 'Limit the total number of items returned to the specified amount.' What a bummer. Thanks! I get the error when trying to create an indexed column on this list. I have no ability to increase the threshold due to my lack of admin access. Is there anyway for me to create an index after the threshold has been exceeded? – James Grizzle Jan 27 '16 at 16:28
  • No, there isn't. If you're using SharePoint on-prem, have an administrator do it for you (or temporarily raise the LVT). If you're using SharePoint Online, you're out of luck -- you must remove items to get under the LVT prior to creating the index (although note that now indexes are created automatically in SPO/SharePoint 2016). – Trevor Seward Jan 27 '16 at 16:30
  • For me the issue was the column i was filtering on didnt have index in it.. after indexing the query worked. Thanx @TrevorSeward – Abdul Hameed Jul 26 '18 at 10:23
0

List view doesn't matter. Internally Sharepoint still has more than 5000 elements and it knows it. SharePoint gets all the items in the list and only after that the list filters are applied.

This is what Microsoft proposes https://support.microsoft.com/en-us/kb/2759051

0

Actually, you need to add an index on the filtered column for the created view

Go to the list and click on “Modify this view” in the ribbon. Under the “Filter” section, you should be able to see which columns are being used for the filter.

Then, navigate to list settings, select "indexed columns" and then "Create a new index" for each filtered column.

That's it!! Now you will be able to get the list items from the view with new index

Hope this resolves your problem.

  • I was not filtering on a column, I used the 'Limit the total number of items returned to the specified amount.' option. – James Grizzle Jan 27 '16 at 19:19
0

I had the same issue. Columns were indexed and used to filter views to ensure none went over the threshold, the total number of items in the entire list was just over 5000 and all views broke, even if they only had 20 items in there!

As a workaround (and this makes no sense) create a new view with no filters, no sorting and no counting/totals and even though there are over 5000 items it displays correctly. You can't filter on any of the columns but you can use the search.

0

Check: there may a People and group column which may exceed limit, ensure that as well

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.