1

I am running some javascript (d3.js, sp.js) in a web part on a sharepoint 2010 site. Everything runs fine when I use chrome or firefox, however when I open the page in IE 11 it does not load correctly and I see the warning:

The attached page targets document mode 8. Some console APIs and features may not be available.

I've tried using the emulator as IE 10 or Edge, but then nothing loads. Any thoughts or suggestions? Thanks!

Update:

I added compatibility mode and emulate IE 10, however it errors at AllItems.aspx, Unable to set property 'outerHTML' of undefind or null reference. If i click play through, everything loads ok.

6
  • 1
    IE 11 must be run in Compatibility View mode. SharePoint 2010/2013 does not support IE 10/11 native/Edge mode. – Trevor Seward Jan 26 '16 at 16:55
  • @TrevorSeward Thanks for the heads us. I added my site to the compatibility list, but now when I load the site I see a large pause icon and the debugger errors: `Unable to set property 'innerHTML' of undefined or null reference'. The line that errors out is not part of my code so I assume it is part of sharepoint. (edit: that is if i enable intranet sites. if I just add to microsoft compatibility lists nothing changes and I receive the same error) – As3adTintin Jan 26 '16 at 17:06
  • I would try to reproduce that error on a page that has zero customizations of the same site template (Team, Publishing, etc.). This should help you determine if you're getting that error from custom code or not. – Trevor Seward Jan 26 '16 at 17:13
  • @TrevorSeward Oh that would be logical. All my other sharepoint pages load fine, so I'm thinking it might be an issue loading the sharepoint API, sp.js? Is there something I can do to further investigate this? – As3adTintin Jan 26 '16 at 17:14
  • also weird, after I turned both compatibility settings on, when I first navigate to my page I receive the original: attached page targets document mode 8. some console api's may not be available, but if I then reload the page that is when I see the large pause button and innerHTML of undefined or null reference – As3adTintin Jan 26 '16 at 17:16
0

Ok so the problem was that Sharepoint 2010 was forcing IE11 to render in IE8. I ended up changing the master file (v4.master) for the specific sharepoint site and editing the <meta> to default to IE=10. It did not affect the other sharepoint sites within my larger sharepoint site, and seems to be working. Thanks, Trevor, for the lead!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.