2

In SP 2013 on prem, I am using content search web part to show customized article pages. The articles are shown in the display template if the article start date is greater than or equal to today.

My issue is this: On the field for start date, if I set it as 27. January, it will show as 26 January in the search index.

This is how the value looks in SharePoint

enter image description here

This is how the value looks while inspecting with the search query tool from CodePlex: (maybe not that clear, but it reads 2016-01-26T23:00:00:000000) enter image description here

Is this a known problem? Anyone else has had it, and know what to do in order to fix this ?

Basically I want my query to work. This is my query, and Date04 is the property of start date (startdato for publisering) that is giving me issues.

ContentTypeId:xxyyzz*  Date04<={Today} Date05>={Today}
  • 1
    Have you tried displaying the times as well as the dates to see whether there's a time zone shift? – Erin L Jan 25 '16 at 16:15
  • Hi, it shows like this: 27.01.2016 00:00, when I show the time in SharePoint, so, it went back 1 hour when inspecting with search query tool. My regional SharePoint setting are set to: (UTC+01:00) Amsterdam, Berlin,Roma,Stockholm,Wien. I am in Oslo, Norway. My SharePoint is built on a Norwegian language pack while my central admin is in English. – Ilyas Jan 26 '16 at 8:26
  • I've run into this before where SharePoint will switch the time entered to local time. But I've never figured out a solution, since I can't adjust for the offset manually because daylight savings time change the offset. Hopefully someone else has an idea. – Erin L Jan 26 '16 at 15:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.